Система передачи сообщений при непрерывной работе SMTP-сервера
Состав работы
|
|
|
|
Необходимые программы
Работа представляет собой zip архив с файлами (распаковать онлайн), которые открываются в программах:
- Microsoft Word
Описание
В некоторых небольших узлах Интернет бывает непрактично поддерживать систему передачи сообщений (MTS - Message Transport System). Рабочая станция может не иметь достаточных ресурсов для обеспечения непрерывной работы SMTP-сервера [RFC-821]. Для “домашних ЭВМ” слишком дорого поддерживать связь с Интернет круглые сутки. Но доступ к электронной почте необходим как для таких малых узлов, так и индивидуальных ЭВМ. Для решения этой проблемы разработан протокол POP3 (Post Office Protocol - Version 3, STD- 53. M. Rose, RFC-1939). Этот протокол обеспечивает доступ узла к базовому почтовому серверу. POP3 не ставит целью предоставление широкого списка манипуляций с почтой. Почтовые сообщения принимаются почтовым сервером и сохраняются там, пока на рабочей станции клиента не будет запущено приложение POP3. Это приложение устанавливает соединение с сервером и забирает сообщения оттуда. Почтовые сообщения на сервере стираются. Более продвинутый и сложный протокол IMAP4 обсуждается в RFC-2060 (порт 143). Об аутентификации в POP3 можно прочесть в документе RFC-1734.
В дальнейшем ЭВМ-клиентом будет называться машина, пользующаяся услугами POP3, а ЭВМ-сервером - сторона, предлагающая услуги POP3. Когда пользователь ЭВМ-клиента хочет послать сообщение, он устанавливает SMTP связь с почтовым сервером непосредственно и посылает все, что нужно через него. При этом ЭВМ POP3-сервер не обязательно является почтовым сервером. В исходный момент ЭВМ POP3-сервер прослушивает TCP-порт 110. Если ЭВМ-клиент хочет воспользоваться услугами POP3-сервера, то устанавливает с ним TCP связь. По установлении связи POP3-сервер посылает клиенту уведомление (например, +OK POP3 server ready) и сессия переходит в фазу авторизации (см. также RFC-1734, -1957). После этого может производиться обмен командами и откликами. Команды POP3 состоят из ключевых слов (3-4 символа), за которыми могут следовать аргументы. Каждая команда завершается парой символов CRLF. Как ключевые слова, так и аргументы могут содержать только печатаемые ASCII-символы. В качестве разделителя используются символы пробела. Каждый аргумент может содержать до 40 символов. Сигнал отклика в POP3 содержит индикатор состояния и ключевое слово, за которым может следовать дополнительная информация. Отклик также завершается кодовой последовательностью CRLF. Длина отклика не превышает 512 символов, включая CRLF. Существует два индикатора состояния: положительный - "+OK" и отрицательный "-ERR" (все символы прописные). Отклики на некоторые команды могут содержать несколько строк. В этом случае последняя строка содержит код завершения 046 ("."), за которым следует CRLF. На практике многострочные отклики для исключения имитации завершаются последовательностью CRLF.CRLF. В процессе авторизации клиент должен представить себя серверу, передав имя и пароль (возможен вариант посылки команды APOP). Если авторизация успешно завершена, сессия переходит в состояние транзакции (TRANSACTION). При получении от клиента команды QUIT сессия переходит в состояние UPDATE, при этом все ресурсы освобождаются и TCP связь разрывается. На синтаксически неузнанные и неверные команды, сервер реагирует, посылая отрицательный индикатор состояния. POP3 сервер может быть снабжен таймером пассивного состояния (10 мин.), который осуществляет автоматическое прерывание сессии. Приход любой команды со стороны клиента сбрасывает этот таймер в нуль. Сервер нумерует все передаваемые сообщения из своего почтового ящика и определяет их длину. Положительный отклик начинается с +OK, за ним следует пробел, номер сообщения, еще один пробел и длина сообщения в октетах. Завершается отклик последовательностью CRLF. Переданные сообщения удаляются из почтового ящика сервера. Все сообщения, передаваемые во время сессии POP3 должны следовать рекомендациям формата Интернет сообщений [RFC822]. В состоянии транзакции клиент может посылать серверу последовательность POP3 команд, на каждую из которых сервер должен послать отклик. Далее следует краткое описание команд, используемых в состоянии транзакция.
В дальнейшем ЭВМ-клиентом будет называться машина, пользующаяся услугами POP3, а ЭВМ-сервером - сторона, предлагающая услуги POP3. Когда пользователь ЭВМ-клиента хочет послать сообщение, он устанавливает SMTP связь с почтовым сервером непосредственно и посылает все, что нужно через него. При этом ЭВМ POP3-сервер не обязательно является почтовым сервером. В исходный момент ЭВМ POP3-сервер прослушивает TCP-порт 110. Если ЭВМ-клиент хочет воспользоваться услугами POP3-сервера, то устанавливает с ним TCP связь. По установлении связи POP3-сервер посылает клиенту уведомление (например, +OK POP3 server ready) и сессия переходит в фазу авторизации (см. также RFC-1734, -1957). После этого может производиться обмен командами и откликами. Команды POP3 состоят из ключевых слов (3-4 символа), за которыми могут следовать аргументы. Каждая команда завершается парой символов CRLF. Как ключевые слова, так и аргументы могут содержать только печатаемые ASCII-символы. В качестве разделителя используются символы пробела. Каждый аргумент может содержать до 40 символов. Сигнал отклика в POP3 содержит индикатор состояния и ключевое слово, за которым может следовать дополнительная информация. Отклик также завершается кодовой последовательностью CRLF. Длина отклика не превышает 512 символов, включая CRLF. Существует два индикатора состояния: положительный - "+OK" и отрицательный "-ERR" (все символы прописные). Отклики на некоторые команды могут содержать несколько строк. В этом случае последняя строка содержит код завершения 046 ("."), за которым следует CRLF. На практике многострочные отклики для исключения имитации завершаются последовательностью CRLF.CRLF. В процессе авторизации клиент должен представить себя серверу, передав имя и пароль (возможен вариант посылки команды APOP). Если авторизация успешно завершена, сессия переходит в состояние транзакции (TRANSACTION). При получении от клиента команды QUIT сессия переходит в состояние UPDATE, при этом все ресурсы освобождаются и TCP связь разрывается. На синтаксически неузнанные и неверные команды, сервер реагирует, посылая отрицательный индикатор состояния. POP3 сервер может быть снабжен таймером пассивного состояния (10 мин.), который осуществляет автоматическое прерывание сессии. Приход любой команды со стороны клиента сбрасывает этот таймер в нуль. Сервер нумерует все передаваемые сообщения из своего почтового ящика и определяет их длину. Положительный отклик начинается с +OK, за ним следует пробел, номер сообщения, еще один пробел и длина сообщения в октетах. Завершается отклик последовательностью CRLF. Переданные сообщения удаляются из почтового ящика сервера. Все сообщения, передаваемые во время сессии POP3 должны следовать рекомендациям формата Интернет сообщений [RFC822]. В состоянии транзакции клиент может посылать серверу последовательность POP3 команд, на каждую из которых сервер должен послать отклик. Далее следует краткое описание команд, используемых в состоянии транзакция.
Похожие материалы
Web-серверы
evelin
: 10 ноября 2012
Все те бесподобные Web-сайты, что вы разработаете и построите при помощи Frontpage, будут, надо полагать, размещаться на Web-сервере. Web-сервер — это компьютер, на котором хранятся Web-сайты, сценарии, базы данных и прочие нужные вещи, а также некая программа, благодаря которым мы имеем удовольствие просматривать в браузере Web-страницы. Так как термин Web-сервер может относиться как к компьютеру, так и к программному обеспечению, то его конкретное значение вам придется угадывать из контекста.
5 руб.
Прокси сервер
JaneQueser
: 14 мая 2012
Содержание
Введение……………………………………………………………………4
Прокси сервер………………………………………………………..4
TCP……………………………………………………………………5
Сокеты………………………………………………………………..9
SOCKS………………………………………………………………10
Реализация…………………………………………………………………12
Функции……………………………………………………………12
Основной алгоритм………………………………………………...17
Ограничения………………………………………………………..19
Приложение 1.Блок-схема………………………………………………20
Приложение 2.Листинг………………………………………………….22
Список литературы……………………………………………………….25
Прокси-сервер (от англ. pr
Антивирусная защита ПО для серверов
alfFRED
: 3 октября 2013
Введение. 3
1 Файл-серверы как один из источников распространения вирусов. 5
2 Антивирусное ПО для серверов локальных сетей. 5
3 Антивирусное ПО для почтовых серверов. 8
4 Антивирус Касперского. 11
5 Doctor Web. 12
6 Symantec. 14
7 Panda. 15
Заключение. 17
Список использованной литературы.. 18
Введение
Одной из самых опасных на сегодняшний день угроз информационной безопасности являются компьютерные вирусы. Компьютерным вирусом называется специально написанная программа, способн
10 руб.
Серверы младшего уровня
Elfa254
: 6 июля 2013
В то время как уровень технического прогресса определяют самые совершенные и высокопроизводительные устройства, к которым приковано внимание прессы и энтузиастов, успехи рынка зачастую зависят вовсе не от них — им принадлежит лишь незначительная доля рынка, основную же прибыль компании-изготовители получают от массовых устройств, «рабочих лошадок» рынка информационных технологий. Это верно и для комплектующих изделий, таких, как ЦП, жесткие диски, системные платы, графические адаптеры, и для гот
10 руб.
Безопасность www-серверов
Elfa254
: 6 июля 2013
Кpаткое описание пpоблемы:
Публичные веб-сеpвеpа пpодолжают оставаться объектами атак хакеpов, котоpые хотят с помощью этих атак нанести уpон pепутации оpганизации или добиться каких-либо политических целей. Хоpошие меpы защиты могут защитить ваш сайт от тех непpиятностей, котоpые будет иметь ваша оpганизация в случае успешной атаки на него.
Уязвимые опеpационные системы:
Любая веpсия Unix или Windows NT, котоpая используется как веб-сеpвеp.
Ущеpб от атаки:
Возможен pазличный ущеpб - от пpостого
5 руб.
Архитектура ЭВМ Компьютеры-серверы
Elfa254
: 24 октября 2013
Чем отличается сервер от обычной рабочей станции?
Предназначение специализированного компьютера-сервера.
Проблемы, решаемы сервером
Специализация
Примеры специализированных серверов
Реализация на практике основных требований, предъявляемых к серверу.
10 руб.
Установка и администрирование WWW -сервера
alfFRED
: 2 октября 2013
3.1 Введение
3.2Общая часть
3.2.1 Назначение WWW - сервера. Общая схема работы. Определение
3.2.2Непосредственные функции сервера. Базовые определения
3.2.3Протокол MIME
3.2.4 Протокол HTTP
3.2.5Интерфейс CGI
3.3Сервер NCSA
3.3.1 Требования к ресурсам
3.3.2 Состав дистрибутива сервера NCSA. Варианты дистрибуции
3.3.3Процедура установки сервера NCSA
3.3.4 Конфигурационные файлы. Режимы работы сервера
3.3.5 Выполнение основных операций администрирования
3.3.5.1 Контроль работоспособности сервера
10 руб.
Технические характеристики современных серверов
GnobYTEL
: 10 ноября 2012
Симметричные мультипроцессорные системы компании Bull
Группа компаний, объединенных под общим названием Bull, является одним из крупнейших производителей информационных систем на мировом компьютерном рынке и имеет свои отделения в Европе и США. Большая часть акций компании принадлежит французскому правительству. В связи с происходившей в последнем пятилетии перестройкой структуры компьютерного рынка компания объявила о своей приверженности к направлению построения открытых систем. В настоящее вр
Другие работы
Курсовая работа по предмету "Основы криптографии" Вариант №07
ZhmurovaUlia
: 7 февраля 2019
Тема: Доказательства с нулевым знанием
Задание:
Выполнить компьютерную реализацию протокола «Задачи о нахождении гамильтонова цикла в графе», используя пример 6.2 (стр. 124 лекций). Номер варианта Z равен последней цифре номера пароля.
Параметры, выбираемые по варианту Z:
1) Случайную нумерацию вершин, используемую в алгоритме (изначально в примере она равна 7 4 5 3 1 2 8 6), необходимо изменить по формуле ((a+Z)mod 9), где a – это цифра исходной последовательности случайных номеров вершин.
2) Н
120 руб.
Гидравлика Задача 13.34 Вариант 49
Z24
: 7 января 2026
В приводах многих машин (прессах, бульдозерах, скреперах подъемниках, станках) применяется схема гидропривода, изображенная на рисунке:
Гидропривод состоит из бака масляного Б, насоса Н, обратного клапана КО, гидрораспределителя Р, гидроцилиндров ГЦ, трубопроводов, предохранительного клапана КП, фильтра Ф.
Значения усилия на штоке F, скорости перемещения рабочего органа (поршня) V, рабочего давления в гидроприводе p и длины трубопроводов l приведены в таблице 2.
Для заданной гидросхемы
350 руб.
Оптическая обработка информации
GAGARIN
: 18 сентября 2013
Вступление
Современная практика и научные исследования требуют измерений высоких и сверхвысоких напряжений — до 10 МВ и больших токов — до 12 МА. Напряжения и токи при этом могут быть постоянными, переменными, и импульсными с длительно-стью импульсов от долей микросекунд до нескольких десятков миллисекунд. Измере-ние больших постоянных токов — до 200500 кА широко используется в устройствах электролиза алюминия. Большие переменные токи — до 150200 кА имеют место в мощных дуговых электропечах. Раб
50 руб.
Контрольная работа по дополнительным главам математического анализа. Вариант №1
temirovchem
: 9 июня 2019
Вариант No 1
1. Найти область сходимости степенного ряда
2. Разложить функцию в ряд Фурье на данном отрезке (период Т)
,
3. Начертить область на комплексной плоскости по данным условиям:
, , , .
4. Вычислить интеграл по дуге от точки до точки
5. Найти частное решение дифференциального уравнения с заданными начальными условиями операторным методом
функция задана графиком
100 руб.